Which vSphere object cannot be upgraded by update manager when running against a legacy host?

An administrator has recently upgraded their update manager infrastructure to vSphere 5. Several hosts and virtual machines have not been upgraded yet.

Which vSphere object cannot be upgraded by update manager when running against a legacy host?

A.
virtual machine hardware

B.
ESX host

C.
ESX patches

D.
VMware tools

Explanation:

Page 142 from vsphere-esxi-vcenter-server-50-upgrade-guide.pdf

5 Comments on “Which vSphere object cannot be upgraded by update manager when running against a legacy host?

  1. AS says:

    From my perspective this question is incomplete.

    According to the VMware vSphere Update Manager 5.0 Release Notes (in http://www.vmware.com/support/vsphere5/doc/vsphere-update-manager-50-release-notes.html#upgrade)

    === Begin note ===

    Interoperability and Software Requirements

    Update Manager can scan and remediate ESX/ESXi hosts, virtual machines, and virtual appliances.

    Host patching
    ESX/ESXi 3.5
    ESX/ESXi 4.x
    ESXi 5.0
    Host upgrades of ESX/ESXi 4.x to ESXi 5.0
    Upgrades of VMware Tools and virtual machine hardware for virtual machines
    Upgrades of virtual appliances

    === End note ===

    Based on this, VUM 5.0 can upgrade VMware Hardware and VMware Tools, can patch ESX and ESXi 3.5 and above, and also can upgrade ESX and ESXi 4.x to ESXi 5.0. ESX/ESXi 3.5 cannot be upgraded because will not have the required minimum 350 MB of space in the /boot
    partition.

    My opinion in the scenario described on this question, probably there are ESX/ESXi3.x and the VMs running on these hosts needs to run a legacy version of VMware Hardware and Tools. Because of this, the VUM cannot upgrade these objects.

  2. Ryan M says:

    Agree with A being the answer. Until the hosts are upgraded to v5, virtual machine hardware v8 is not supported, as indicated by the table in the reference.

  3. Alex says:

    It’s asking what VUM can’t update, not what a legacy ESX host will run. Also, that charts shows that running VC 5 (which you have to have to run VUM5) can run v4/7/8. It states “legacy host”, so we have to assume 3.X and as “AS” is showing, VUM 5 can only do host upgrades for ESX/i 4. The answer should be B.


Leave a Reply

Your email address will not be published. Required fields are marked *